ZModeler v2.2.5 (16 Feburary 2011)

ZModeler2-related discussion. General questions, howto, etc.

Moderators: Oleg, _RicH_

ZModeler v2.2.5 (16 Feburary 2011)

Postby Oleg » Wed Feb 16, 2011 4:54 am

ZModeler v2.2.5 Build 986 release notes.

Requirements.
This version have been compiled with the latest DirectX 9 version available, so your current system might not match system requirements of ZModeler. You should upgrade or download and update you DirectX installation. DirectX 9.0c June 2010 Redist should be installed:
http://www.microsoft.com/downloads/en/d ... CEB6D8FA8D

This version resolves a long-stading issue with Import/Export filters conflict when they support the same file extension. There is no particular need to discard support of old versions of games (like NFS:MostWanted) when consequential game title uses the same file extension but can't be managed by single plugin.

The same issue I faced with Test Drive Unlimited 2. It uses the same file extension but differs so much internally, so it's pretty hard to keep management of different files in the same filter. From now on different filters for the same file extension will be available and managed properly by ZModeler.

Test Drive Unlimited2 filter
This version includes initial release of import-only filter for Test Drive Unlimited2. You still need external tools to unpack .BIG files and extract zmodeler-compatible files from .BNK archieves.

Follow up to TDU2 thread for more details here:
http://forum.zmodeler2.com/viewtopic.php?t=5072
Last edited by Oleg on Fri Feb 25, 2011 2:30 am, edited 1 time in total.
User avatar
Oleg
Site Admin
 
Posts: 7644
Joined: Fri Feb 06, 2004 3:54 am

Serial key problem

Postby El1iP3S01D » Wed Feb 16, 2011 7:24 am

Oleg, since updating Zmodeler, my serial key isn't working can you help me?
El1iP3S01D
 
Posts: 66
Joined: Sat Jan 15, 2011 2:50 pm
Location: Queens, NY USA

Postby Reinhard » Wed Feb 16, 2011 7:40 am

Just re-apply the activation key.

The procedure is described in the activation mail you got, when you bought the program.

I just did so after upgrading, and it went fine.

Please don't post any of the mail content here.
User avatar
Reinhard
Beginner
 
Posts: 271
Joined: Tue Sep 15, 2009 10:38 am
Location: Berlin, Germany

My z modeler will not run??

Postby guest » Wed Feb 16, 2011 10:13 am

Hello I am using windows vista and everytime that I try to run z modeler it say windows has stopped working.... any ideas????
guest
 

Postby Oleg » Wed Feb 16, 2011 1:01 pm

Try different compatibility modes on Zmodeler shortcut. I don't have vista, but ZModeler works fine on XP and Win7 here.
User avatar
Oleg
Site Admin
 
Posts: 7644
Joined: Fri Feb 06, 2004 3:54 am

Postby smokey8808 » Wed Feb 16, 2011 5:15 pm

since the update we cant import NFS HP .bin files anymore. did specifiy the file type in the drop down menu, zm shows nothing after importing tho.
smokey8808
 
Posts: 90
Joined: Fri Jul 17, 2009 12:25 pm

Postby Kotton » Wed Feb 16, 2011 5:27 pm

+1 no nfsHp import here either

and I've already lost my second channel remapping of the doors that were assigned 3 channels by default

just like I reported in this thread --> http://forum.zmodeler2.com/viewtopic.php?t=4937
User avatar
Kotton
 
Posts: 97
Joined: Mon Dec 08, 2008 2:51 pm
Location: IE, SoCal

Postby Oleg » Thu Feb 17, 2011 1:39 am

nfshp vs carbon filter conflict fixed. get updated.

regarding uv get lost, you should (somehow) try to isolate the case when it happens. I doubt I could find the source of the problem having a description of the work you've done.
User avatar
Oleg
Site Admin
 
Posts: 7644
Joined: Fri Feb 06, 2004 3:54 am

Postby Toolieo » Thu Feb 17, 2011 3:19 am

Hello,

Oleg since the update ive also noticed that Zmodeler doesn't export a .xml for NFS Shift cars.

I was using it to update the .vhf files, could you please fix it?
Toolieo
 

Postby Oleg » Thu Feb 17, 2011 3:26 am

It wasn't exporting xml. The xml vhf exporting was made on request and that version of filter was not available in standard version.
User avatar
Oleg
Site Admin
 
Posts: 7644
Joined: Fri Feb 06, 2004 3:54 am

Postby Reinhard » Thu Feb 17, 2011 3:36 am

Another notice: ZMAutoUpdate.exe dies with a windows error message now, when there is no update available.

I auto-upgraded to 2.2.5 successfully, yesterday. When I restarted an update trial shortly after, out of curiosity, I got the error. I downloaded the whole zip and replaced ZMAutoUpdate then, but this didn't help.

Today, I was able to upgrade for the latest fixes. Now, with an up-to-date Zmodeler, ZMAutoUpdate throws an error again.

Not really a problem, but might confuse the user. So this is just for information.
Last edited by Reinhard on Thu Feb 17, 2011 3:53 am, edited 1 time in total.
User avatar
Reinhard
Beginner
 
Posts: 271
Joined: Tue Sep 15, 2009 10:38 am
Location: Berlin, Germany

Postby smokey8808 » Thu Feb 17, 2011 3:52 am

Oleg wrote:nfshp vs carbon filter conflict fixed. get updated.


thank you, works again.
smokey8808
 
Posts: 90
Joined: Fri Jul 17, 2009 12:25 pm

Postby Oleg » Thu Feb 17, 2011 4:13 am

Reinhard wrote:Another notice: ZMAutoUpdate.exe dies with a windows error message now, when there is no update available.


Thank you. I've improperly removed old "TDU1" filter from updates server. It should be ok now. The update client was also fixed to avoid crash in such a case, you can redownload updated version.
User avatar
Oleg
Site Admin
 
Posts: 7644
Joined: Fri Feb 06, 2004 3:54 am

Postby Guest » Thu Feb 17, 2011 4:20 am

Oleg wrote:The xml vhf exporting was made on request and that version of filter was not available in standard version.


So you won't do that again?

Damn...
Guest
 

Postby Reinhard » Thu Feb 17, 2011 4:23 am

The update client was also fixed to avoid crash in such a case, you can redownload updated version.

Confirmed, works even without downloading a new instance, now. Like proposed, so it really was the lack of files. New version is installed and also confirmed okay.

Thanks.
User avatar
Reinhard
Beginner
 
Posts: 271
Joined: Tue Sep 15, 2009 10:38 am
Location: Berlin, Germany

Postby Oleg » Thu Feb 17, 2011 5:11 am

Anonymous wrote:
Oleg wrote:The xml vhf exporting was made on request and that version of filter was not available in standard version.


So you won't do that again?

Damn...


I've made an option for it in Export dialog of Shift filter. Get updated.
User avatar
Oleg
Site Admin
 
Posts: 7644
Joined: Fri Feb 06, 2004 3:54 am

Postby toolieo » Thu Feb 17, 2011 5:31 am

Thank you very much. :)
toolieo
 

Postby Kotton » Thu Feb 17, 2011 9:55 am

many thanks for the update Oleg

about the 3rd channel/missing UV coordinates issue
both times it happened is when I was messn with a carbon texture - so lets look at the commonalities-

1] the part has a 3rd channel
2] channel 2 is being modified
3] the second channel texture is unchecked in the material editor (hidden)
4] the uv coordinates are then scaled really big (super big)
5] after the mapping is done, and the UV mapper window is closed, the 2nd channel texture is checked (visible) - and that's when I see the mapping is gone

guess I'll try to duplicate it using those commonalities and see what happens..
User avatar
Kotton
 
Posts: 97
Joined: Mon Dec 08, 2008 2:51 pm
Location: IE, SoCal

Postby Murph90 » Thu Feb 17, 2011 7:44 pm

error
Last edited by Murph90 on Tue Sep 11, 2012 1:31 pm, edited 1 time in total.
User avatar
Murph90
 
Posts: 12
Joined: Fri Oct 01, 2010 8:37 pm
Location: Australia

Postby smokey8808 » Thu Feb 17, 2011 7:48 pm

noticed strange behaviour when trying to import a locked gta4 wft file to 2.2.5.

in earlier version, you could see a comment and a greyed-out import button. now, you can click import - although nothing happens, so the lock still seems to work.

minor bug it seems.
smokey8808
 
Posts: 90
Joined: Fri Jul 17, 2009 12:25 pm

Postby Kotton » Thu Feb 17, 2011 9:01 pm

damn.. that defeats the security system we've implemented :/

each person we hook a mod up with gets a fresh export and new number.. that way, if any of those people upload it to another site, we can
DL the file and 'import' it to see the displayed number and who it belongs to, and not allow that person access to our mods in the future...

Oleg, if possible, please reinstate that very crucial feature (stored comments and greyed out import button)-
User avatar
Kotton
 
Posts: 97
Joined: Mon Dec 08, 2008 2:51 pm
Location: IE, SoCal

Postby Oleg » Fri Feb 18, 2011 1:30 am

updated.
User avatar
Oleg
Site Admin
 
Posts: 7644
Joined: Fri Feb 06, 2004 3:54 am

Postby Kotton » Fri Feb 18, 2011 1:21 pm

many thanks Oleg works perfectly.. Image

however, a few of us have noticed another issue specifically with TDU2 meshes..
some parts of the convertibles are not viable.. seems to be the opening part (HANIM_S)
import any spyder with that named part and the result is the same :/

Image Image
User avatar
Kotton
 
Posts: 97
Joined: Mon Dec 08, 2008 2:51 pm
Location: IE, SoCal

Postby Murph90 » Fri Feb 18, 2011 2:07 pm

still isn't importing gta sa

1. click import
2. choose file
3. import
4. wait
5.freeze
User avatar
Murph90
 
Posts: 12
Joined: Fri Oct 01, 2010 8:37 pm
Location: Australia

Postby Oleg » Sat Feb 19, 2011 5:53 am

Kotton, I don't have the game. If you found a problem, upload the file. I've used only "California" model and it's HANIM_S object is fine.
User avatar
Oleg
Site Admin
 
Posts: 7644
Joined: Fri Feb 06, 2004 3:54 am

Next

Return to ZModeler2 General Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests