ZModeler v2.2.6 (08 November 2011)

ZModeler2-related discussion. General questions, howto, etc.

Moderators: _RicH_, Oleg

ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Tue Nov 08, 2011 4:24 am

ZModeler v2.2.6 Build 992 release notes.

Requirements.
This version have been compiled with the latest DirectX 9 version available, so your current system might not match system requirements of ZModeler. You should upgrade or download and update you DirectX installation (DirectX 9.0c June 2010 Redist)
(http://www.microsoft.com/en-us/download ... px?id=8109) and additionally, the following package should be installed:
http://www.microsoft.com/download/en/de ... x?id=26347

You should have the whole set of Visual Studio 2005 Redistributive packages installed. These are optional components and might be missing on your system, so make sure to install all of them:

VC 2005 Redistributive (2006.04.10)
VC 2005 Redistributive SP1 (2007.08.27)
VC 2005 Redistributive SP1 ATL (2010.09.20)
VC 2005 Redistributive SP1 MFC (2011.06.07)

Installing these packs is a must if you get an error at startup:
Code: Select all
The application has failed to start because it's side-by-side configuration is incorrect. Reinstalling application may fix the problem...



Updates:
This version extends support of filters with the same file extension to File\Export feature too. You should note, that exporting with specific filter type that can conflict with another filter (e.g. TestDriveUnlimited2 filter imports/export the same files as TestDriveUnlimited1 filter) should be performed from File\Export dialog box. Do not use drop-down menus next to Import/Export buttons in a main toolbar for such a files.

Test Drive Unlimited2 filter
This version includes updated version of TDU2 filter that can export models now. Refer to according filter guide thread for more details:
http://forum.zmodeler2.com/viewtopic.php?t=5375
User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Reinhard » Tue Nov 08, 2011 6:27 am

I made 2 installments of 2.2.6: A full fresh download, and an upgrade of 2.2.5 (ZMAutoUpdate).

The upgraded version fails to import 18wos PMG (no files found, and PMG not listed in available file types).

Copying the ".../Filters/ConvoyPMG.zmf" from the full download did solve the problem. Prior to that, the files where different, as a quick hex compare revealed. So I guess that the auto-update of the PMG filter file simply failed.
User avatar
Reinhard
Beginner
 
Posts: 256
Joined: Tue Sep 15, 2009 10:38 am
Location: Berlin, Germany

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Tue Nov 08, 2011 7:30 am

Fixed. It should be Ok now.
User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Reinhard » Wed Nov 09, 2011 3:56 am

Oleg, is it by intent that this PMG filter merges all meshes in the same object directory, whilst import, if these have no name? For several unnamed dummies I got with the old filter, now only a single one is left in each folder. Dummies which have a name applied are still left separated, at least a quick look let me think so.

Edit: a picture to make it more clear:
Image
This is both an import of the same /prefab/tradeaux_warehouse/tradeaux.pmg
User avatar
Reinhard
Beginner
 
Posts: 256
Joined: Tue Sep 15, 2009 10:38 am
Location: Berlin, Germany

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Wed Nov 09, 2011 4:29 am

yes, it is intended; you can untick "Merge Models" in Import dialog box to leave objects separated by materials like in 2.2.5.
User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Reinhard » Wed Nov 09, 2011 4:45 am

Fine, thanks, didn't saw that.

Hey, the initial "Origin" setting is fixed. Nice. How often I forget to set it in the first run. :D
User avatar
Reinhard
Beginner
 
Posts: 256
Joined: Tue Sep 15, 2009 10:38 am
Location: Berlin, Germany

Re: ZModeler v2.2.6 (08 November 2011)

Postby xiorxorn » Sun Nov 13, 2011 11:59 pm

Hi Oleg,

I just download the new v2.2.6 build992 and something don't work to me.
I have no texture Service.
The TexturesService.zms is present in the Services directory(216KB)
But
no texture tool in bar
Image
no "services" in settings box
Image
I can't load textures in materials
When i try to load an image in the background of a view, i read an error : "Can't obtain textures service. file:backImageLayer.cpp line:305"


Don't know how to solve this problem
My OS is Vista
I try two way to install the v2.2.6 (AutoUpdate and normal download)-> same conclusion

Thanks for reading
User avatar
xiorxorn
 
Posts: 2
Joined: Mon Oct 18, 2010 12:36 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Mon Nov 14, 2011 12:08 am

User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby xiorxorn » Mon Nov 14, 2011 12:23 am

It works fine with that.

Thank you very much
User avatar
xiorxorn
 
Posts: 2
Joined: Mon Oct 18, 2010 12:36 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby ajayextreme09 » Mon Nov 14, 2011 8:06 am

@ Oleg

is it 100% working export filter for TDU2 ?? i cant belive

Thank you very much

so will you make a simple car mod which shows us how to convert cars for TDU2

add it into you sample download list
ajayextreme09
 
Posts: 32
Joined: Sun Nov 13, 2011 11:02 pm
Location: INDIA

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Mon Nov 14, 2011 8:14 am

Nope, I'm not a modder or 3d artist. I personally do not convert any 3D formats. I just import stock model and export it. If it works fine, I assume that "any" 3D scene can be adjusted properly and converted. :wink:
User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Murrchachosa » Thu Nov 17, 2011 4:32 pm

I keep getting error when opening Zmodeler226.
I installed everything needed, 224 worked well, except using the mouse in Perspective mode.
But this version won't open, error.

Vista Home x64, all DX are up to date, vredit thingy 2008 installed.
Framenetwork is the latest version, and directx_jun2010_redist is installed.
No, I keep getting that error.

Do you really need to have each version more required programs? :(
Murrchachosa
 
Posts: 31
Joined: Sun Feb 03, 2008 5:24 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Thu Nov 17, 2011 11:40 pm

Murrchachosa wrote:I keep getting error when opening Zmodeler226.
I installed everything needed, 224 worked well, except using the mouse in Perspective mode.
But this version won't open, error.


vcredist_x86 installed, right? The one with publishing date June'11?
http://www.microsoft.com/download/en/de ... x?id=26347

Murrchachosa wrote:Do you really need to have each version more required programs? :(

It's not me, sorry. Microsoft publishes updates that AutoUpdate thing installs on my PC. And then, eventually, any build of ZModeler becomes affected. I've noticed this first time with ZModeler 2.2.5 and didn't installed any updates that would affect builds since then (just to avoid this thing with reidist and other stuff needed).

But I'm developing ZModeler3 on the same PC and I had to install the latest updates to be sure that it's up-to-date-safe. :) I didn't intended to make ZModeler2 updates, but TDU2 did required it.

In fact, it's possible to make a bigger install package and supply all required libraries next to ZModeler, so it can surely start (I do think that ZModeler3 will be shipped this kind of fullness).
User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Murrchachosa » Fri Nov 18, 2011 5:31 am

Oleg wrote:
Murrchachosa wrote:I keep getting error when opening Zmodeler226.
I installed everything needed, 224 worked well, except using the mouse in Perspective mode.
But this version won't open, error.


vcredist_x86 installed, right? The one with publishing date June'11?
http://www.microsoft.com/download/en/de ... x?id=26347

Murrchachosa wrote:Do you really need to have each version more required programs? :(

It's not me, sorry. Microsoft publishes updates that AutoUpdate thing installs on my PC. And then, eventually, any build of ZModeler becomes affected. I've noticed this first time with ZModeler 2.2.5 and didn't installed any updates that would affect builds since then (just to avoid this thing with reidist and other stuff needed).

But I'm developing ZModeler3 on the same PC and I had to install the latest updates to be sure that it's up-to-date-safe. :) I didn't intended to make ZModeler2 updates, but TDU2 did required it.

In fact, it's possible to make a bigger install package and supply all required libraries next to ZModeler, so it can surely start (I do think that ZModeler3 will be shipped this kind of fullness).


Ah ok, it's all clear now.
Sorry about that.

Yes, I installed the link you gave, that vcredist_x86 is installed.
I installed it 3 times, it's still not working.

Does it needs other Framenetwork version installed?
Murrchachosa
 
Posts: 31
Joined: Sun Feb 03, 2008 5:24 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Fri Nov 18, 2011 9:09 am

nope, it doesn't need any framework libs at all.

Zmod is made with Microsoft Visual Studio 2005; The following updates were applied, but I got no idea which "redist package" they are coming with:
Code: Select all
Security Update for Microsoft Visual Studio 2005 Professional Edition - ENU (KB2251481)   
Security Update for Microsoft Visual Studio 2005 Professional Edition - ENU (KB2465367)   
Security Update for Microsoft Visual Studio 2005 Professional Edition - ENU (KB2538218)   
Security Update for Microsoft Visual Studio 2005 Professional Edition - ENU (KB2548826)   
Security Update for Microsoft Visual Studio 2005 Professional Edition - ENU (KB971090)   
Security Update for Microsoft Visual Studio 2005 Professional Edition - ENU (KB973673)   

:?

DirectX 9 June 2010 update is required for textures plugin to work too.
User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Reinhard » Fri Nov 18, 2011 11:57 pm

Out of curiosity, I just upgraded an old Zmodeler installation in my Win 7 notebook.

Got the texture service problem also and tried the DirectX end-user redistributable, hence:


The installer extracted a bunch of files, but then died, silently, without updating anything.

After a while, I noticed that the page quoted above links also to a "websetup" version of the runtime package, which did the trick for me.

So if the package doesn't properly install on anyones system, go to the microsoft-page and scroll down to "Additional information". Point 4 of the list has the link to the other version.
User avatar
Reinhard
Beginner
 
Posts: 256
Joined: Tue Sep 15, 2009 10:38 am
Location: Berlin, Germany

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Sat Nov 19, 2011 3:56 am

Once you've unpacked files, you should run dxsetup.exe manually.
User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby GTARandom » Fri Dec 02, 2011 4:58 am

Oleg , will you fix WFT completely for IV?

I want to create map objects with fragments.

And how are corona powers added?
GTARandom
 
Posts: 9
Joined: Sun Jul 11, 2010 10:16 am
Location: Zagreb

Re: ZModeler v2.2.6 (08 November 2011)

Postby Sleepy93HUN » Sat Dec 10, 2011 6:07 am

hello all!

my zmodeler always has crash when i try export a car to wft ...

i made the hierarchy ... and materials ...
so they are good
the dummies are good so i don't know why crashes the zmodeler...

please help ! :)

has gtaiv import/export script any bugs?

i tried to export all version of zmodeler which can export to wft ... but all versions crashes ... so ?
could somebody help?
Sleepy93HUN
 
Posts: 2
Joined: Mon Nov 23, 2009 5:33 am
Location: Ferencváros/Budapest/Hungary

Re: ZModeler v2.2.6 (08 November 2011)

Postby Guest » Thu Dec 15, 2011 11:51 pm

Hi,

I just downloaded and tried version 226 and am getting this error message.

C:\Program Files (x86)\ZModeler226\ZModeler2.exe

The application has failed to start because its side-by-side configuration is incorrect. Please
see the application event log or use the command-line sxstrace.exe tool for more detail.

I installed vcredist_x86.exe, vcredist_x64.EXE & directx_Jun2010_redist.exe. I rebooted and still get the same error message. I have windows 7 Ultimate 64 bit. Do you have any suggestions on how to get it to work for me. Version 225 works fine, just not V226. I don't know what else to do.

Thanks

John
Guest
 

Re: ZModeler v2.2.6 (08 November 2011)

Postby Tattoo » Thu Dec 15, 2011 11:54 pm

Oops, I made the post above. I didn't realize I wasn't logged in. Now I can attach a screen shot of the error message window.

Help Please.

Thanks
Attachments
Capture.png
Tattoo
 
Posts: 7
Joined: Thu Dec 15, 2011 11:39 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Fri Dec 16, 2011 12:03 am

User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Tattoo » Fri Dec 16, 2011 1:51 pm

Oleg wrote:http://www.microsoft.com/download/en/details.aspx?id=26347

I installed vcredist_x86.exe, vcredist_x64.EXE & directx_Jun2010_redist.exe. I rebooted and still get the same error message. I have windows 7 Ultimate 64 bit. Do you have any suggestions on how to get it to work for me. Version 225 works fine, just not V226. I don't know what else to do.
Tattoo
 
Posts: 7
Joined: Thu Dec 15, 2011 11:39 pm

Re: ZModeler v2.2.6 (08 November 2011)

Postby Oleg » Fri Dec 16, 2011 9:47 pm

run windows update and make sure your win7 is up to date. I have a win7 on laptop and never intalled any addons like vcredist there. zmod runs there just fine, since win7 is updated automatically.
User avatar
Oleg
Site Admin
 
Posts: 3418
Joined: Fri Feb 06, 2004 3:54 am

Re: ZModeler v2.2.6 (08 November 2011)

Postby Tattoo » Fri Dec 16, 2011 11:12 pm

Oleg wrote:run windows update and make sure your win7 is up to date. I have a win7 on laptop and never intalled any addons like vcredist there. zmod runs there just fine, since win7 is updated automatically.

I ran Windows update many times and installed all of the updates that are available already. I will do it again to see if there are any new updates but as far as I know it's fully updated already.

EDIT: ok I ran it and there are new updates that I don't have yet. Will install them and report back if it works or not.

Thanks Oleg...
Tattoo
 
Posts: 7
Joined: Thu Dec 15, 2011 11:39 pm

Next

Return to ZModeler2 General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest