spining axis problem

GTA:V Modding with ZModeler3 discussion.

Moderator: madga182

spining axis problem

Postby tall70 » Sat Dec 16, 2017 3:39 pm

I'm trying to rotate axis in properties, both axis X and Z are spinning only Z...am i missing something, or bug?

https://drive.google.com/open?id=1bxJA--0yIVMgVDa_8Lonv9wyRQyBDX_R
User avatar
tall70
Beginner
 
Posts: 466
Joined: Tue Aug 11, 2015 3:13 pm

Re: spining axis problem

Postby Oleg » Sat Dec 16, 2017 10:15 pm

can you send me a .z3d file with just this object in it?
User avatar
Oleg
Site Admin
 
Posts: 8059
Joined: Fri Feb 06, 2004 3:54 am

Re: spining axis problem

Postby tall70 » Sun Dec 17, 2017 1:34 am

sending
Attachments
gearsend.z3d
(1.64 MiB) Downloaded 14 times
User avatar
tall70
Beginner
 
Posts: 466
Joined: Tue Aug 11, 2015 3:13 pm

Re: spining axis problem

Postby Oleg » Sun Dec 17, 2017 1:44 am

this is a confusion of axes rotation order. when you specify rotation angles, they can't be applied all at once, they are applied in order X, then Y, then Z. When you have Y set to 90, doing so will make Z axis point to X after rotation. So, rotation 30, 90, 0 (30 x then 90 y then 0 z) is identical to rotation 0, 90, 30 (0 x then 90 y and then "30 z which is identical to original 30 x before Y rotation").
User avatar
Oleg
Site Admin
 
Posts: 8059
Joined: Fri Feb 06, 2004 3:54 am

Re: spining axis problem

Postby tall70 » Sun Dec 17, 2017 10:39 pm

Maybe there was misunderstanding, it works fine in game, i need to spin it in zmodeler over same axis game does, which is red one X axis, ans i need to spin it same rotation angle as it's set in game and UDO for this gear. However there is no way it would happen on axis X. It will work perfectly fine on Y and Z, just not X, setting X will spins same as setting Z. And i had to do this before to make landing gear and landing gear doors work, because they have their normal position open unlike regular doors. So i select landing gear dummy, go in properties and change number as visible on screen in first post and you can see how both axis spin same....If there is still something i don't understand, please give me short description how to spin gear dummy (which will spin mesh with it) over red axis X 37 degrees...which thats what it does in game as i have it set in UDO

I'm doing it in properties only temporarily to get something else working, but it's the only way to set precise location of retracted gear
User avatar
tall70
Beginner
 
Posts: 466
Joined: Tue Aug 11, 2015 3:13 pm

Re: spining axis problem

Postby Oleg » Mon Dec 18, 2017 3:04 am

you can't do this in properties window when final rotation is on several axes at a time. setting axes rotation on several axes at a time is ambiguous as could be reached by several different rotations on axes depending on rotations order. For example, if your gear does not define 82 (90) rotation on Y, it will go fine with rotation on X and Z in properties window.
User avatar
Oleg
Site Admin
 
Posts: 8059
Joined: Fri Feb 06, 2004 3:54 am

Re: spining axis problem

Postby tall70 » Mon Dec 18, 2017 7:50 am

It's just strange how it's skipping spinning one of the axis, but the other two are just doing it fine, but I understand if it's impossible I can probably do what I need different way, thanks

It's weird, I had to also fit landing gear doors, they also have angles and I had to have them closed, then spinned them in its open position for export
User avatar
tall70
Beginner
 
Posts: 466
Joined: Tue Aug 11, 2015 3:13 pm


Return to Grand Theft Auto V

Who is online

Users browsing this forum: No registered users and 5 guests

cron