Report Import/Export bugs here

GTA:V Modding with ZModeler3 discussion.

Moderator: madga182

Re: Report Import/Export bugs here

Postby _Vlad_ » Sat Dec 24, 2016 1:08 am

also please check spec_decal shader, model with this shader located here x64j.rpf\levels\gta5\_citye\hollywood_01\hw1_01.rpf\hw1_01_decalsb2.ydr
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby 240p » Tue Dec 27, 2016 3:22 pm

I am unable to import GTA Online character model pieces, such as glasses, shirts, etc. The result is a dummy. Anyone got any ideas as to why I'm getting this instead of the model?
Image
I opened the importer so you can see my options for further diagnostics.
User avatar
240p
 
Posts: 1
Joined: Mon Dec 26, 2016 5:30 pm

Re: Report Import/Export bugs here

Postby _Vlad_ » Wed Dec 28, 2016 5:08 am

240p wrote:I am unable to import GTA Online character model pieces, such as glasses, shirts, etc. The result is a dummy. Anyone got any ideas as to why I'm getting this instead of the model?
I opened the importer so you can see my options for further diagnostics.

lol, did you toggle L0 ?
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby _Vlad_ » Thu Jan 05, 2017 10:57 am

@Oleg, i'm exporting ydd with embedded texture - game crashed
but when exported without embedded texture from the same zm scene - worked fine
so, it's a game bug or not? but some ydd has the embedded textures, forgot to say, it's a map part (some ydd of map object has embedded textures too)
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby Oleg » Thu Jan 05, 2017 11:13 am

is your .ydd a ped/player model?
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: Report Import/Export bugs here

Postby _Vlad_ » Thu Jan 05, 2017 11:18 am

@Oleg, no, as i say in previous post its a map part, it's lod of map part, like lod1
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby Oleg » Thu Jan 05, 2017 1:49 pm

have you tried different "Base" values? when embedded textures are used, it's very likely to have dual Base value set on original models, like

Base 10, 5

I guess the second value could be related to memory usage of embedded textures. Give it a try in two steps:
1. embed just one very small texture (e.g. 4x4 placeholder), just to find out whther it will work or not;
2. do #1 but this time add dual Base value in user-defined properties like Base 12, 2.
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: Report Import/Export bugs here

Postby _Vlad_ » Fri Jan 06, 2017 1:58 am

this object has Base 17, 0
so, i tried Base 17, 8 but it's not work, but maybe i don't understand you correctly
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby Oleg » Fri Jan 06, 2017 2:45 am

have you tried this model with just one very small embedded texture in it?
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: Report Import/Export bugs here

Postby _Vlad_ » Fri Jan 06, 2017 2:54 am

@Oleg, yes, still crasing with 4x4 texture
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby _Vlad_ » Fri Jan 06, 2017 3:34 am

@Oleg, so, any solution or should i use different base setting? default is 17, 0
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby _Vlad_ » Fri Jan 06, 2017 7:40 am

btw, after reexporting file with trees_lod and trees_lod2 shaders, game always crashed
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby _Vlad_ » Fri Jan 06, 2017 8:01 am

@Oleg, well, i'm reexported my map object with Gims, with embedded textures and it's working.
In zm show Base 6, 1, default was Base 17, 0
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby Oleg » Fri Jan 06, 2017 11:12 am

can you send me the .ydr created by zmod and by gims/odr for compare? I doubt the "Base 6, 1" is the cause, something else might be wrong.
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: Report Import/Export bugs here

Postby _Vlad_ » Fri Jan 06, 2017 8:39 pm

@Oleg, sure, but as i said before it's ydd
but for some weird reason, now zm export only 1 texture of 3, but yesterday it's was ok, so, i' m attached my z3d and .ydd, exported from gims

also, after reexporting untouched bh1_46_c_grnd (model with new terrain shaders, which one was recently added) i always got this error bh1_46_c_grnd
Incorrect multy-texture layer MODE set on material "BH1_46_HC_Rockface_01".
but model is exported

btw, do you know another shaders, except emissivenight_geomnightonly which support emissive at night and hide this emessive geometry part at night?
emissivenight_geomnightonly doesnt support alpha channel, but i need it
Attachments
models.rar
.z3d +ydd from gims
(432.5 KiB) Downloaded 22 times
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby Oleg » Sat Jan 07, 2017 7:21 am

1. the warning on export is not a problem; it will get fixed in next update when I add new shaders;

2. try emissivenight_alpha
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: Report Import/Export bugs here

Postby _Vlad_ » Sat Jan 07, 2017 8:48 am

@Oleg, ok, thanks!
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby Oleg » Sun Jan 08, 2017 11:12 am

_Vlad_ wrote:btw, after reexporting file with trees_lod and trees_lod2 shaders, game always crashed

The problem might be related to the same issue with embedded texture inside .ydd file.

In any case, can you specify the file I could test this on? I've tried trees_lod objects added onto bh1_46c_grnd object and these work fine. then tried trees_lod on .ydd file and it works fine too.
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: Report Import/Export bugs here

Postby Oleg » Sun Jan 08, 2017 11:13 am

@_Vlad_, the crash on .ydd files containing embedded textures is fixed. get an update.
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: Report Import/Export bugs here

Postby _Vlad_ » Sun Jan 08, 2017 12:27 pm

@Oleg, awesome, thanks!
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby _Vlad_ » Sun Jan 08, 2017 12:45 pm

@Oleg, now its working, the model with trees_lods and trees_lod2 was with embedded textures,
Btw, after this fix of embedded textures, it's not possible to export this textures from ydd via OpenIV, but anyway thanks a lot for fix!
Can you please take a look at "normal_pxm" and "terrain_cb_w_4 yr_spec_pxm" shaders? model here x64l.rpf\levels\gta5\_citye\sunset\ss1_13.rpf\ss1_13_grd03noshad.ydr
there's screen, but from console http://i.imgur.com/hhB9Igm.jpg, i can make any screen's you need
Last edited by _Vlad_ on Sun Jan 08, 2017 12:58 pm, edited 1 time in total.
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby Oleg » Sun Jan 08, 2017 12:55 pm

nope, you just need to locate an entry inside ydd that actually contains embedded textures. It's the very first that used them in your scene (it's not a must to be the first in a list in OpenIV).

Also, talking on ped models as an example, if you try to locate embedded texture for "lower" model and your "upper" model has embedded texture too (and "upper" is above "lower" in a list), you should look for embedded textures on "upper" entry, it will contain all embedded textures for the rest of entries (below it in a list).
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

Re: Report Import/Export bugs here

Postby _Vlad_ » Sun Jan 08, 2017 12:59 pm

@Oleg, i updated the post
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby _Vlad_ » Sun Jan 08, 2017 10:51 pm

when i adapt material to emessivenight_alpha, zm says :
Shader "emissivenight_alpha" should use Undefined.R affection on DETAIL.
what i should do to fix that? but model is exported, it's just a warning
_Vlad_
Beginner
 
Posts: 156
Joined: Thu Aug 06, 2015 11:30 pm

Re: Report Import/Export bugs here

Postby Oleg » Mon Jan 09, 2017 4:45 am

set Emissive color affection to DETAIL.A

Also, feel free to report locations of game models that use terrain/trees shaders, so I can inspect them. Just file names could be enough, in rare cases in-game location of the model might be needed so I could teleport and see in-game render of specific shader.

these are terrain and trees shaders in game, as you know just few of them are ported in zm importer/exporter:

terrain_cb_4lyr
terrain_cb_4lyr_2tex
terrain_cb_4lyr_2tex_blend
terrain_cb_4lyr_2tex_blend_lod
terrain_cb_4lyr_2tex_pxm
terrain_cb_4lyr_cm
terrain_cb_4lyr_cm_tnt
terrain_cb_4lyr_lod
terrain_cb_4lyr_pxm
terrain_cb_4lyr_spec
terrain_cb_w_4lyr
terrain_cb_w_4lyr_2tex
terrain_cb_w_4lyr_2tex_blend
terrain_cb_w_4lyr_2tex_blend_lod
terrain_cb_w_4lyr_2tex_blend_pxm
terrain_cb_w_4lyr_2tex_blend_pxm_spm
terrain_cb_w_4lyr_2tex_blend_pxm_tn_spm
terrain_cb_w_4lyr_2tex_blend_pxm_tt_spm
terrain_cb_w_4lyr_2tex_blend_tt
terrain_cb_w_4lyr_2tex_blend_ttn
terrain_cb_w_4lyr_2tex_pxm
terrain_cb_w_4lyr_cm
terrain_cb_w_4lyr_cm_pxm
terrain_cb_w_4lyr_cm_pxm_tnt
terrain_cb_w_4lyr_cm_tnt
terrain_cb_w_4lyr_cm_tnt_pxm
terrain_cb_w_4lyr_lod
terrain_cb_w_4lyr_pxm
terrain_cb_w_4lyr_pxm_spm
terrain_cb_w_4lyr_spec
terrain_cb_w_4lyr_spec_int
terrain_cb_w_4lyr_spec_int_pxm
terrain_cb_w_4lyr_spec_pxm
trees
trees_camera_aligned
trees_camera_facing
trees_lod
trees_lod2
trees_lod2d
trees_lod_tnt
trees_normal
trees_normal_diffspec
trees_normal_diffspec_tnt
trees_normal_spec
trees_normal_spec_camera_aligned
trees_normal_spec_camera_aligned_tnt
trees_normal_spec_camera_facing
trees_normal_spec_camera_facing_tnt
trees_normal_spec_tnt
trees_normal_spec_wind
trees_shadow_proxy
trees_tnt
User avatar
Oleg
Site Admin
 
Posts: 7828
Joined: Fri Feb 06, 2004 3:54 am

PreviousNext

Return to Grand Theft Auto V

Who is online

Users browsing this forum: No registered users and 1 guest