Car extra and suspension issue

GTA:V Modding with ZModeler3 discussion.

Moderator: madga182

Car extra and suspension issue

Postby Algonquin_Hood » Mon Apr 09, 2018 2:37 pm

Hello, I have the following issue:
Extra parts detach parts they are not supposed to detach.
https://gyazo.com/885266944437b441aa3ccdeb81f22f77
For example, if I take extra_3 off ingame, it will make the front bumper disappear.
Removing extra_2 will make extra_1 disappear
I tried moving it upwards and downwards in the hierarchy, moving the Children around but that didn't help.
https://gyazo.com/e6e1167884b455115db88042729be9ee

Second issue is the suspension. I moved the dummy to every plausible position, but it always moves like this under compression:
https://gyazo.com/42dafbbf92a29eaa459b906e13c3cb78
Obviously it's supposed to compress, instead of going sideways.

Thanks in advance
Algonquin_Hood
 
Posts: 40
Joined: Wed Dec 24, 2014 8:04 am

Re: Car extra and suspension issue

Postby Oleg » Tue Apr 10, 2018 6:42 am

add collision to extra object.
User avatar
Oleg
Site Admin
 
Posts: 8272
Joined: Fri Feb 06, 2004 3:54 am

Re: Car extra and suspension issue

Postby Algonquin_Hood » Wed Apr 11, 2018 5:49 am

Oleg wrote:add collision to extra object.

Thanks for your response.
I added collision to all respective extra parts, no improvement whatsoever (collision works ingame). Just out of curiosity I moved all extras from the bottom of the hierarchy to the very top. Extra 1 works completly fine, Extra 2 and Extra 3 make anything below them in the hierarchy disappear.
Also, here's a better view of the suspension situation:
https://gyazo.com/f095b92e8fae097d41dc0e9d7707cd61
Algonquin_Hood
 
Posts: 40
Joined: Wed Dec 24, 2014 8:04 am

Re: Car extra and suspension issue

Postby Oleg » Thu Apr 12, 2018 3:36 am

import model back and ensure hierarchy is 100% retained (matches the one on export), including location of COL objects in hierarchy. Also, try a "gta_parts.xml" fix, it might be related to the issue too. the file is attached to a sticky guide thread on top and should be placed into "Install" folder.
User avatar
Oleg
Site Admin
 
Posts: 8272
Joined: Fri Feb 06, 2004 3:54 am

Re: Car extra and suspension issue

Postby Algonquin_Hood » Thu Apr 12, 2018 6:49 am

I controlled the hierarchy and everything is the same. I also exported with gta_parts.xml but nothing changed. I worked my way around by removing one of the faulty extras completly, so I'm only left with one faulty extra now. Placing that on the very bottom of the hierarchy fixed the issue. As for suspension, dummy is on the same position on the suspension mesh as it was on the car I took the original suspension dummy and mesh from. Reseting axis to parent didn't help, so I went all lazy and attached suspension mesh to my transmission_f and transmission_r mesh lol

EDIT: I also found the dials to be missing. I remember fixing this on one car by just grabbing dials and their material from original Rockstar model and merging, but it doesn't seem to work on this project.
Algonquin_Hood
 
Posts: 40
Joined: Wed Dec 24, 2014 8:04 am

Re: Car extra and suspension issue

Postby tall70 » Thu Apr 12, 2018 9:59 am

Then try some different experiments, if you have more than one extra like 3 or 4, remove one temporarily see if it's gonna suddenly work, maybe it's gonna isolate some accident mistake. I had extras functions completely messed up, then I removed extra 12 coffee cup and Bam all extras worked as intended and set up in hiearchy
User avatar
tall70
Beginner
 
Posts: 484
Joined: Tue Aug 11, 2015 3:13 pm


Return to Grand Theft Auto V

Who is online

Users browsing this forum: No registered users and 2 guests

cron