Shader config not aplly IG

GTA:V Modding with ZModeler3 discussion.

Moderator: madga182

Shader config not aplly IG

Postby ShaezB » Wed Jan 11, 2017 7:37 am

Yop,
I've try to set different thing like texture transition, texture tiles, use per vertex color, opaque , matted etc
And i'm able to set it to my taste in zmodeler but once I export and look the object IG, all these thing dissapear (tile reseted, transition totaly disapear, use alpha source instead of color etc.
I guess I need to input something in user defined option in order that what i'm setting also apply IG, but can't find any list of the option ;S
Also may i'm wrong and it come from another thing idk
ShaezB
 
Posts: 15
Joined: Wed Dec 07, 2016 3:10 am

Re: Shader config not aplly IG

Postby Oleg » Wed Jan 11, 2017 12:41 pm

You mess with zmodeler-specific settings on materials that are no way related to exported materials. Zmodeler materials allow very flexible configuration and in-game materials are "ported" to same predefined configuration with almost no variety of settings. For simplicity of materials configuration, you should use a configuration script button - the big button with "gears" in top-right corner of materials browser.
User avatar
Oleg
Site Admin
 
Posts: 7026
Joined: Fri Feb 06, 2004 3:54 am

Re: Shader config not aplly IG

Postby ShaezB » Wed Jan 11, 2017 11:16 pm

well if you talk about the circle icon with a gear then it's already the one i use so i guess i forget something more
And except basic thing like texture (and again, only the main cause the texture of transition and his settings dissapear from the material), their level, dif/env/spec color / etc save, all other are reseted when I reopen the object ;S
ShaezB
 
Posts: 15
Joined: Wed Dec 07, 2016 3:10 am

Re: Shader config not aplly IG

Postby Oleg » Wed Jan 11, 2017 11:37 pm

most of shaders have no transitions in game. some terrain shaders have transitions to blend different texture packs (e.g. different kinds of grass and ground). In rare cases transition map is a placeholder for a texture that is not ported properly onto ZModeler shares: all parallax-height shaders put height-map into transition of BUMPMAP, but it is not actually a bump texture, just a placeholder to put texture into.
User avatar
Oleg
Site Admin
 
Posts: 7026
Joined: Fri Feb 06, 2004 3:54 am

Re: Shader config not aplly IG

Postby ShaezB » Thu Jan 12, 2017 12:25 am

ok so i could still search ;Pthen i'm gonna try to find an other way to hide that
between, about the user defined option, i saw some about tilesscale etc, I was expecting that maybe they were a list of the different options ?
ShaezB
 
Posts: 15
Joined: Wed Dec 07, 2016 3:10 am

Re: Shader config not aplly IG

Postby Oleg » Thu Jan 12, 2017 12:36 am

each shader has its own set of parameters. "uv tile" might appear on some sharers that share mapping across different texture samplers. for example, all *_detail shaders do that (normal_detail, vehicle_detail etc.) when addition "detail" texture uses UV#1 but is allowed to set tile value on U and V.

You can see each shader parameters in OpenIV on "More Information" -> "Shaders" page.

ZModeler puts into user-defined options just few of parameters that are not explicitly ported to (set onto/read from) shader properties.
User avatar
Oleg
Site Admin
 
Posts: 7026
Joined: Fri Feb 06, 2004 3:54 am

Re: Shader config not aplly IG

Postby ShaezB » Sat Jan 14, 2017 3:16 am

yep thank i got it ;)
ShaezB
 
Posts: 15
Joined: Wed Dec 07, 2016 3:10 am


Return to Grand Theft Auto V

Who is online

Users browsing this forum: No registered users and 2 guests

cron