error in my log

SCS Software ATS and ETS2 editing using ZModeler3 filter. Models, Materials, Animation.

Moderators: Oleg, _RicH_

error in my log

Postby Cerritos » Wed Jan 03, 2018 10:36 pm

I have this error in my log although I do not have problems in the game I would like to eliminate, any idea why is it?
regards

Code: Select all
00:04:11.117 : <ERROR> [baked_model] Too many indices in 'chassis' (100298) for material '/vehicle/truck/kenworth_w900_lyb/chrome.mat'
00:04:11.117 : <ERROR> [baked_model] Pieces using same material '/vehicle/truck/kenworth_w900_lyb/negro.mat' and parameter packets have different vertex buffer layout {size: 36, .position:FLOAT_3@0, .normal:FLOAT_3@12, .color:UBYTE_4_NORM@24, .tex_coord_0:FLOAT_2@28} vs {size: 44, .position:FLOAT_3@0, .normal:FLOAT_3@12, .color:UBYTE_4_NORM@24, .tex_coord_0:FLOAT_2@28, .tex_coord_1:FLOAT_2@36}
00:04:11.118 : <ERROR> [baked_model] Creation of 'cabin' baked model failed
Cerritos
 
Posts: 7
Joined: Fri Feb 24, 2017 7:05 am

Re: error in my log

Postby Oleg » Wed Jan 03, 2018 11:06 pm

material "negro.mat" is used by objects with different vertices/format properties. in particular, some objects use 1 uv channel, other objects use 2 uv channels. this is likely to happen if you export different scenes into the same folder (e.g. truck.pmd and interior.pmd) and get material conflict: one scene export refers to material negro.mat with geometry using only 1 uv channel and another file got exported with a reference to this material and geometry utilizing 2 uv channels. This is unlikely to happen when exporting one scene into this folder only.
User avatar
Oleg
Site Admin
 
Posts: 8065
Joined: Fri Feb 06, 2004 3:54 am

Re: error in my log

Postby Cerritos » Thu Jan 04, 2018 5:49 am

I will review my models, thanks
Cerritos
 
Posts: 7
Joined: Fri Feb 24, 2017 7:05 am


Return to ATS and ETS2 by SCS Software

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest