Headlights SCS SCANIA 2016

SCS Software ATS and ETS2 editing using ZModeler3 filter. Models, Materials, Animation.

Moderators: Oleg, _RicH_

Headlights SCS SCANIA 2016

Postby Harald-RS » Wed Nov 22, 2017 11:46 pm

Hello Oleg,

i have a Problem with the Headlights from the SCS SCANIA 2016.

As soon as I the floodlights after him import again would like to export.

If the indicators and day driving lights do not function any more.

I am real in despair.

I wanted to sit down for the indicators still Flares purely with it the indicators more hard shine the same one is valid for the day driving light.

I hope you can help.
Greetings
Harald
Sorry for my bad english, i from germany.
User avatar
Harald-RS
 
Posts: 56
Joined: Sun Oct 21, 2012 8:08 am
Location: Neuburg / Germany

Re: Headlights SCS SCANIA 2016

Postby Steinmetz Omi » Fri Mar 02, 2018 1:37 am

Yes , i can confirm that, see you pictures.

Image
Image

Import with Zmodeler3 64bit Version 3.2.0 (1179)
Steinmetz Omi
 
Posts: 4
Joined: Fri Oct 09, 2015 1:55 pm

Re: Headlights SCS SCANIA 2016

Postby Steinmetz Omi » Fri Apr 06, 2018 10:03 am

Hello Oleg !
The Bug isn`t solved , what is the problem ?
Steinmetz Omi
 
Posts: 4
Joined: Fri Oct 09, 2015 1:55 pm

Re: Headlights SCS SCANIA 2016

Postby Oleg » Fri Apr 06, 2018 10:29 am

can you specify location of files you import, and post a screenshot from in-game: an original model (where it works fine) and after model have been import/exported.

also, have you tried to put original contents of associated .MAT file into a mod to find out whether this is related to material file or to geometry model?
User avatar
Oleg
Site Admin
 
Posts: 8272
Joined: Fri Feb 06, 2004 3:54 am

Re: Headlights SCS SCANIA 2016

Postby Harald-RS » Sat Apr 14, 2018 11:41 pm

Hello Oleg,

I used the original Mats,

the only one where there had been a new mat was for the glass, since I tinted them in yellow or blue and tinted black. Wanted to do.

z_mod3_uv_mapping_chanale_2 _wrong_after_import.JPG
The UV 2 : was destroyed after import.
z_mod3_uv_mapping_chanale_1 _correct_after_import.JPG
The UV 1: was correct
Greetings
Harald
Sorry for my bad english, i from germany.
User avatar
Harald-RS
 
Posts: 56
Joined: Sun Oct 21, 2012 8:08 am
Location: Neuburg / Germany

Re: Headlights SCS SCANIA 2016

Postby Oleg » Sun Apr 15, 2018 12:51 am

I've checked the file and it seems to use UV#1 on both DETAIL and DETAIL2 (MASK?) slots. The contents of UV#2 looks like trash and unused in game. Just switch material's DETAIL2 slot to "Manual UV#1" on "lamp.add.env" material before export.

Note, this "UV channel config" is suppressed by geometry definition inside a model file, so it can not be configured properly when importing a model (different geometry fragments can give their own channel usage on the same material), so materials are always created with default channels assignment. This issue is identical to "truckpaint" material where you have to specify correct UV channel usage on DETAIL2 slot to get model exported properly and paint-ready.
User avatar
Oleg
Site Admin
 
Posts: 8272
Joined: Fri Feb 06, 2004 3:54 am


Return to ATS and ETS2 by SCS Software

Who is online

Users browsing this forum: No registered users and 1 guest