Skin brocken after export

SCS Software ATS and ETS2 editing using ZModeler3 filter. Models, Materials, Animation.

Moderators: Oleg, _RicH_

Skin brocken after export

Postby StAfFoRdShIrE » Sat Oct 15, 2016 7:53 am

Hello Oleg,
since the last update ZM3 I have problems with my skins.
Before import into ZM3 skins are in place, the mapping is correct, then after export under ZM3, everything is wrong.
I tested under Blener and everything is good.

I have only added a few pieces (lollipop, exhaust, etc ...) and I have not touched the mapping.
The .mat are good and my .dds

I do not see where the problem may come.

Thanks in advance for the help.


Before: (and export whit Blender)
Image



After: (and export whit ZM3)
Image
StAfFoRdShIrE
 
Posts: 16
Joined: Fri Jan 11, 2013 2:16 pm

Re: Skin brocken after export

Postby Oleg » Sat Oct 15, 2016 10:41 am

check the "DETAIL2" texture slot on "truckpaint" material. You might need to change "UV Source" there to "Manual UV#3" before an export (as it natively loaded as Manual UV#2 in most of cases).
User avatar
Oleg
Site Admin
 
Posts: 7398
Joined: Fri Feb 06, 2004 3:54 am

Re: Skin brocken after export

Postby StAfFoRdShIrE » Sun Oct 16, 2016 2:53 am

Thank you also for the quick response.

I checked and the uv mapping is "Manual UV # 3" I tested with "Manual UV # 2" and it's good for the skin truck, but suddenly the texture is very matte.

The problem is also present on the additional parts I changed (sideskit, backlignht, etc ...) is all that is related to texture "truckpaint".
A small patch on the next update ZM3 could solve this problem?


So I continue to search for the solution to this problem.
StAfFoRdShIrE
 
Posts: 16
Joined: Fri Jan 11, 2013 2:16 pm

Re: Skin brocken after export

Postby Oleg » Sun Oct 16, 2016 3:58 am

StAfFoRdShIrE wrote:I checked and the uv mapping is "Manual UV # 3" I tested with "Manual UV # 2" and it's good for the skin truck, but suddenly the texture is very matte.


can you quote here an original truckpaint .mat file and the one created by ZModeler?
User avatar
Oleg
Site Admin
 
Posts: 7398
Joined: Fri Feb 06, 2004 3:54 am

Re: Skin brocken after export

Postby StAfFoRdShIrE » Sun Oct 16, 2016 5:31 am

Original
material : "eut2.truckpaint.tsnmapuv16.altuv.fx" {
texture[0] : "/vehicle/truck/volvo_fh16_2012/carpaint_ao.tobj"
texture_name[0] : "texture_base"
texture[1] : "/vehicle/truck/volvo_fh16_2012/carpaint_n.tobj"
texture_name[1] : "texture_nmap"
texture[2] : "/material/environment/vehicle_reflection.tobj"
texture_name[2] : "texture_reflection"
add_ambient : 0
diffuse : { 1 , 1 , 1 }
env_factor : { 0.073239 , 0.073239 , 0.073239 }
fresnel : { 0.2 , 0.9 }
shininess : 250
specular : { 1.5 , 1.5 , 1.5 }
}




ZM3
material : "eut2.truckpaint.tsnmap.airbrush.altuv.fx" {
texture[0] : "/vehicle/truck/volvo_fh16_2012/textures/carpaint_ao.tobj"
texture_name[0] : "texture_base"
texture[1] : "/material/environment/vehicle_reflection.tobj"
texture_name[1] : "texture_reflection"
texture[2] : "/vehicle/truck/volvo_fh16_2012/textures/carpaint_n.tobj"
texture_name[2] : "texture_nmap"
texture[3] : "/vehicle/truck/volvo_fh16_2012/textures/empty.tobj"
texture_name[3] : "texture_paintjob"
add_ambient : 0
aux[8] : { 0.6 , 0.05 , 0.05 }
diffuse : { 1.0 , 1.0 , 1.0 }
env_factor : { 0.0732389 , 0.0732389 , 0.0732389 }
fresnel : { 0.2 , 0.9 }
shininess : 250
specular : { 0.184644 , 0.184644 , 0.184644 }
}
StAfFoRdShIrE
 
Posts: 16
Joined: Fri Jan 11, 2013 2:16 pm

Re: Skin brocken after export

Postby Oleg » Sun Oct 16, 2016 10:09 am

.airbrush can not appear on its own; a user-defined option named "AIRBRUSH" is needed for this option to appear in an exported .mat file;

.tsnmapuv16 is changed to .tsnmap because of:
1. a bump-map texture is missing (exporter has failed to detect texture type: whether it is ATI2 or regular DXT image).
2. BUMPMAP should use UV Source: Manual UV#2 probably, while it uses Manual UV#1.

P.S. The .pmd/.pmg format allows user-defined UV channels mixing on a model, while ZModeler's import/export uses standard pre-defined UV channels ordering. Even more, the model can suppress material settings and has its own specific UV channels assignment (e.g. UV#2 for base texture, UV#1 for paintjob and bumpmap and like this). Some model might fail to load with correct UV channel assigned and, as a result, being exported with no changes will get wrong mapping in game.

Always check "truckpaint" material texture slots UV source assignment, as this material is more likely to be affected by this issue. Try various UV Source in BUMPMAP and DETAIL2 settings to see whether any of them will work properly in game.
User avatar
Oleg
Site Admin
 
Posts: 7398
Joined: Fri Feb 06, 2004 3:54 am

Re: Skin brocken after export

Postby StAfFoRdShIrE » Mon Oct 17, 2016 3:11 am

OK I'll check that.

I will inform you of the progress of my problem.


Thank you again for what you do
StAfFoRdShIrE
 
Posts: 16
Joined: Fri Jan 11, 2013 2:16 pm

Re: Skin brocken after export

Postby StAfFoRdShIrE » Mon Oct 17, 2016 9:45 am

True :D :D :D

Image

Thank you for your help.

I use ZM for several years and I am not about to change program for 3d!!!


Thank you Oleg :wink:
StAfFoRdShIrE
 
Posts: 16
Joined: Fri Jan 11, 2013 2:16 pm


Return to ATS and ETS2 by SCS Software

Who is online

Users browsing this forum: No registered users and 1 guest

cron