GTA4 WFT Export discussion

GTA San Andreas and GTA Vice City discussion.

Moderators: Oleg, _RicH_

Postby Neos7 » Thu Jul 02, 2009 12:20 pm

that's what i was trying to say...lol
but when i export my edited .wft file with new textures
i got this error to clipboard
Object "banshee.wft" was not found. Whole scene will be exported.
Missing shader configuration for shader "gta_vehicle_MOMO_Corse_gm" in material "MOMO_Corse_gm". Defaulting to "gta_default".
Missing shader configuration for shader "gta_vehicle_conti" in material "conti". Defaulting to "gta_default".
Missing shader configuration for shader "gta_vehicle_conti-sc2" in material "conti-sc2". Defaulting to "gta_default".
Missing shader configuration for shader "gta_vehicle_brake" in material "brake". Defaulting to "gta_default".


and the added parts are untextured how to fix it?
User avatar
Neos7
 
Posts: 89
Joined: Wed May 27, 2009 12:51 am
Location: Napoli

Postby Chasez » Thu Jul 02, 2009 12:44 pm

This is my unfinished model :D:D:D
Image
Image
User avatar
Chasez
Beginner
 
Posts: 249
Joined: Thu Jun 18, 2009 12:34 am

Postby LeX91 » Thu Jul 02, 2009 1:04 pm

Chasez, excellent model! We also have something which works for testing conversion:
Image
Image
LeX91
 

Postby Chasez » Thu Jul 02, 2009 1:30 pm

LeX91 wrote:Chasez, excellent model! We also have something which works for testing conversion:
Image
Image


your model is missing something. I'm working on textures now, searching the way to save them and for now I'm done with modeling:) And what do you mean by ''well, who's the coolest?''
User avatar
Chasez
Beginner
 
Posts: 249
Joined: Thu Jun 18, 2009 12:34 am

Postby Mr. BerK » Thu Jul 02, 2009 1:39 pm

Chasez wrote: I'm working on textures now, searching the way to save them and for now I'm done with modeling:)


Hey! When u find a way to save the new textures, plz, tell me how to do this. I want to export the new textures sooo much. lol
Mr. BerK
 

Postby Chasez » Thu Jul 02, 2009 1:45 pm

Mr. BerK wrote:
Chasez wrote: I'm working on textures now, searching the way to save them and for now I'm done with modeling:)


Hey! When u find a way to save the new textures, plz, tell me how to do this. I want to export the new textures sooo much. lol


I've seen that few people uses DDS Converter 2.1. I'm gonna check that out :)
User avatar
Chasez
Beginner
 
Posts: 249
Joined: Thu Jun 18, 2009 12:34 am

Postby LeX91 » Thu Jul 02, 2009 1:47 pm

Chasez, yes there are many problems, including the textures. but the main thing that drives already = D Gradually all want the problem solved. I do not I have a car, I just laid out a photo, make a friend, and he left an inscription, too = D
LeX91
 

New Edit

Postby Mr. BerK » Thu Jul 02, 2009 2:20 pm

Hello guys. Here i am, again. :)

Now with a Street Racing Blista. All parts using original game textures. Take a look:

http://g.imagehost.org/view/0993/GTAIV_ ... 0-42-41-98
http://g.imagehost.org/0156/GTAIV_2009- ... -57-61.png
http://g.imagehost.org/0960/GTAIV_2009- ... -02-52.png
http://g.imagehost.org/view/0372/GTAIV_ ... 0-43-07-12
http://g.imagehost.org/view/0168/GTAIV_ ... 0-45-09-95

Bye. I hope the error when exporting new textures will be fixed soon. :roll:
Mr. BerK
 

Postby JKM » Thu Jul 02, 2009 3:20 pm

Chasez wrote:
Mr. BerK wrote:
Chasez wrote: I'm working on textures now, searching the way to save them and for now I'm done with modeling:)


Hey! When u find a way to save the new textures, plz, tell me how to do this. I want to export the new textures sooo much. lol


I've seen that few people uses DDS Converter 2.1. I'm gonna check that out :)


Use paint.net and convert your textures to a dds with general attitudes.
Then search download G-Texture and build your own *.wtd file. Don't forget to generate MipMaps with G-Texture.
Then open ZModeler2 and change any material from an imported wft model. Don't forget to check "use defined options" in the material editor and then export your model.
Change wft and wdt with SparkIV and see how your own textures will work in IV.
Believe me I am doing it for my self and it works great:
Image Image

ZM will give you an error while exporting the wft with your own textures, but its working ingame. So dont bother!
JKM
 
Posts: 12
Joined: Sat Jul 23, 2005 10:39 am

Postby Mr. BerK » Thu Jul 02, 2009 3:31 pm

Thanx, JKM. Gonna try it right now. :)
Mr. BerK
 

Postby Mr. BerK » Thu Jul 02, 2009 5:27 pm

So, sr. JKM, i did everything that u said, and this is what happened:

http://f.imagehost.org/0229/bug.jpg

Ah man, so much work, and that fu**** wheel just disappear. :cry:
Mr. BerK
 

Postby FUBAR » Thu Jul 02, 2009 9:42 pm

Hi everybody,

Yesterday I also started to convert a new car for GTAIV. I used the '68 Mustang Fastback from Carface, because its one of my favourite.^^
In the first Ingametest, I only saw the windows of the car but nothing else. *lol*
After some testing with the materials, I found out that you have to rename the textures like the textures of the original schafter (for example: "mesh", "tire", "paint1", ....)
Then you can see the textures of the car.
Unfortunately I can't create a new .wtd file at the moment with GForce so I have exported with Spark an another .wtd file. I just used one with a lot of texture files in it, so I can replace more then just four, like in the original schafter .wtd file.
And it works good. :)

The only problem that I have so far is, that the complete wheel is very shiny because of the reflections. And I don't know why. I just can't change the reflections of the wheel.
But all other parts looking real good. It's just the wheel.

Futhermore I have a another little problem. If I drive around and steer, the car turn completely over. Even by slow speed.
Is that because of the collisionsmodel or what could it be? :?:


I'm at work at the moment, so I can't post a ingamepicture. I will show you some pics if I'm at home. :wink:
Except the shiny wheel, the car looks very great ingame. Can't wait to convert more cars ingame. Especially my other own models. :)
So, thanks Oleg, for the export filter. Very good work. :wink:

Greets, FUBAR
FUBAR
 

Postby Oleg » Thu Jul 02, 2009 9:49 pm

Chasez, do not use your high-detailed model for lower-detail mesh (copying L0 to L1 isn't probably a good choice).

Also, there are some issues with mesh layout in wft file yet - a random "hedgehog" can still appear. I'll try to make more accurate vertices layout to avoid this effect (it could be a cause for a crash when you hit the car or shot it).

Currently, take an advice: the problem is usually in low-detailed mesh (since high-detailed is exported first and conform GTA4 needs). Either reduce detailzation of low-detailed mesh, or split it more materials:


select all L1 parts. (hide the rest). Select mode ON. Right-click\Properties will show you a list of used materials and amount of polygons using each material. Write down the names of mostly-used materials (those with more than 4000 polygons).

when all L1 parts are selected, switch to selected mode and switch them ALL to polygons level.
deselect all polygons. using Select\By Material select the mostly used material polygons (the first from the list you've made above).
Using Select\Quadr and holding CTRL key down, you can deselect polygons on left side of the car in front view.
In materials editor, create a copy of material in a question. Select a copied version (the last in a list) and press "Assign to selection".
Hide selected polygons.

Then "spread heavy usage" of materials to a copies (like you did above) with the rest of materials in your list. Literally, you need to reduce usage of ONE material by the mesh. If certain material is used too much, create a copy of it and assign some of polygons to a copy of it.


The text above is for Distorted "hedgehog" model problem.
User avatar
Oleg
Site Admin
 
Posts: 7635
Joined: Fri Feb 06, 2004 3:54 am

Postby Chasez » Thu Jul 02, 2009 10:20 pm

Thanks, Oleg :)
User avatar
Chasez
Beginner
 
Posts: 249
Joined: Thu Jun 18, 2009 12:34 am

Postby Oleg » Thu Jul 02, 2009 11:39 pm

GTA4 Materials and textures was added. it's incomplete, but you should read it indeed.
User avatar
Oleg
Site Admin
 
Posts: 7635
Joined: Fri Feb 06, 2004 3:54 am

Postby JKM » Fri Jul 03, 2009 12:45 am

Mr. BerK wrote:So, sr. JKM, i did everything that u said, and this is what happened:

http://f.imagehost.org/0229/bug.jpg

Ah man, so much work, and that fu**** wheel just disappear. :cry:


Strange. My wheels disappear too. But for chassis components it works^^

@Oleg: is the bumpmap setup still the same in the Material Editor?
JKM
 
Posts: 12
Joined: Sat Jul 23, 2005 10:39 am

Postby Lexan » Fri Jul 03, 2009 2:06 am

кстати проблема с Schafterом может быть еще из-за того что он сам по себе со всеми включенными экстрами является уникальным бандкаром - Schafter Russian Mafia - и вполне возможно,т.к. нету экстр у скорой - приводить к ошибке..список банд каров на сайте у меня =

http://www.kamazoff.ru/modules.php?name=Pages&page=34

schafter - the special extra (Band Cars) - and all extra.- if not all extra - game is crash maybe !
Lexan
 
Posts: 4
Joined: Mon Dec 18, 2006 8:45 am
Location: Russia/Samara

Postby owenwilson1 » Fri Jul 03, 2009 3:54 am

can someone help me im pretty new to this ..everything i place ingame mostly is invisible
help its proberly somthing silly. please help thanks in advance
owenwilson1
 

Postby Chasez » Fri Jul 03, 2009 4:17 am

Mr. BerK wrote:
Chasez wrote: I'm working on textures now, searching the way to save them and for now I'm done with modeling:)


Hey! When u find a way to save the new textures, plz, tell me how to do this. I want to export the new textures sooo much. lol


So texture creator work :) you gotta download the DDS Converter 2.1. When you have done that, open the converter, you will have to choose texture file to convert (you can select as much as you want), the only format that it alows to convert is png. In options select DXT1 for normal textures. press convert and it's done.

Next step, open the G-texture and create new WTD file and after that just add the DDS format textures and save the file and that should be it :)
User avatar
Chasez
Beginner
 
Posts: 249
Joined: Thu Jun 18, 2009 12:34 am

Postby Guest » Fri Jul 03, 2009 4:45 am

owenwilson1 wrote:can someone help me im pretty new to this ..everything i place ingame mostly is invisible
help its proberly somthing silly. please help thanks in advance


its okay i got it working
Guest
 

Postby Flash » Fri Jul 03, 2009 6:09 am

Hey Guest (Page 1)
Can you upload that civil police cruiser?
I love that car!
Flash
 

Postby Chasez » Fri Jul 03, 2009 6:21 am

I have a problem with wheel :( I tried everything I knew and I even tried the settings from the original wheel but this is what I get -
now, this wheel is in SparkIV and it's ok Image
but in the game it makes look like this Image
and I noticed that the wheel is mirrored to the other side Image
What could be the problem? btw I modified the ADMIRAL model :)
User avatar
Chasez
Beginner
 
Posts: 249
Joined: Thu Jun 18, 2009 12:34 am

Postby EmsterFan » Fri Jul 03, 2009 6:29 am

reset your axis to the world (orientation-mode)
EmsterFan
 
Posts: 23
Joined: Thu May 22, 2008 3:41 am

Postby Chasez » Fri Jul 03, 2009 6:49 am

EmsterFan wrote:reset your axis to the world (orientation-mode)


it doesn't work :( it does switches the sides in the zmodeler but in the game it's still the same.

EDIT:

Nevermind I got it working :D after reseting axis to the world I had to rotate it's geometry and now it's working :) now I gotta solve some other problems (wheel blimping when I'm driving and very annoying reflection) and the wheel will be fully working and textured :) btw it's from san andreas ford crown victoria model :)
Last edited by Chasez on Fri Jul 03, 2009 7:11 am, edited 1 time in total.
User avatar
Chasez
Beginner
 
Posts: 249
Joined: Thu Jun 18, 2009 12:34 am

Postby Guest » Fri Jul 03, 2009 7:09 am

We are making good progress, and quickly move on))) but for us the problem was that the rear wheel with each new convert becoming thinner and thinner = (
our progress:
ImageImage
Guest
 

PreviousNext

Return to Grand Theft Auto

Who is online

Users browsing this forum: No registered users and 2 guests